Started almost 2 years agoJuly 31, 2024Lasted about 3 hoursJuly 31, 20244:096:59 PMUTC
Affected
https://panel.preyproject.com/
Degraded performance from 4:09 PM to 6:59 PM
Updates
Resolved
UTC
Resolved
UTC
This issue has been resolved.
Investigating
UTC
Investigating
UTC
We are currently investigating this issue. If you are installing Prey and having issues, or having slow responses while performing actions on the Prey panel, please try again later.